Announcement

Collapse
No announcement yet.

[UPDATED 5/16] A.I. Templates - Bot, Car, & +Flying AI

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by drb1992 View Post
    Could we possibly get a new link for the 4.9 car AI? The existing link isn't working anymore.
    Ouch that hurts. I have the project downloaded, would it be ok if I reuploaded it somewhere?

    Comment


      Originally posted by Zireael07 View Post
      Ouch that hurts. I have the project downloaded, would it be ok if I reuploaded it somewhere?
      I would definitely appreciate it.
      Logitech Wheel Plugin

      Comment


        Originally posted by drb1992 View Post
        I would definitely appreciate it.
        Links have been fixed.

        Though I am focusing my efforts on a new plugin. If you're interested, please follow the link below.

        https://forums.unrealengine.com/show...n-SequencerPro

        Comment


          Hello peter, just a question, does the Car AI 4.9.1 version have something like the AI following a spline path? My AI has the basic outcome of following specified actors but I don't know how I would do that with splines though.

          Comment


            How do you change which character the ai targets

            Comment


              Never mind, the user "masterneme" got it to work Click image for larger version

Name:	branch.png
Views:	2
Size:	341.4 KB
ID:	1123847
              you just have to switch the true and false

              Comment


                I'm having the most insane time trying to crack the Car AI basing it off this. When I run the level the behavior tree shows a route key of "none." In the sample project I can get it to do the same thing if I add a second car, but I have absolutely no clue how to begin figuring this out.

                EDIT: NVM, got tat figured out. Still doesn't update to the next waypoint, but it at least it moves to one...
                Last edited by Timbiat; 04-22-2017, 06:53 AM.

                Comment


                  Originally posted by Timbiat View Post
                  I'm having the most insane time trying to crack the Car AI basing it off this. When I run the level the behavior tree shows a route key of "none." In the sample project I can get it to do the same thing if I add a second car, but I have absolutely no clue how to begin figuring this out.

                  EDIT: NVM, got tat figured out. Still doesn't update to the next waypoint, but it at least it moves to one...
                  Hey! Still having issues?

                  Peter

                  Comment


                    fyi: just tested it with 4.15.1. works fine for me
                    Thx again for this!

                    Comment


                      Hey, I updated the Attack/Search/Patrol TPP A.I. project, I just organized the all codes and made update for 4.15

                      https://www.mediafire.com/?jb5fj3fjbij7i8b

                      Comment


                        Hey Peter, Im trying to spawn in the AISedan as an enemy, and I have it set to spawn at a specific time, but when it spawns it doesnt follow the waypoint, it just moves backwards and forwards randomly. I belive it is to do with my level blueprint, which is also wha tI used to spawn in the enemies.

                        Click image for larger version

Name:	ProblemCarPls.PNG
Views:	1
Size:	308.6 KB
ID:	1132230

                        Comment


                          How do you increase the size of the waypoint hit activation in the SedanAI?

                          edit: it's in the update movement component of the sedan blueprint, time to kick it up to hyperspeed.....
                          Last edited by MikeRPG; 09-28-2017, 10:22 PM.

                          Comment


                            Can someone post a link to a video that shows the results?

                            Comment


                              Hey Peter! This is amazing stuff and I am glad I discovered you. I do have a question though. I want to be able to set the FlyingAI as a homing target. I have set the meshes to the collision preset "Pawn" which is what I have my Homing Target variable set to target. The AI registers being hit with the line trace but never seems to be set as a target. In wireframe mode I see only the UFOTop as a purple outline while the main mesh UFO does not show up at all. How would I go about being able to target this thing? TIA

                              Comment

                              Working...
                              X